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Introduction

This chapter introduces SimBiology® functions and features to help you
develop a conceptual model for working with the software and your
biochemical data.

¢ “Product Overview” on page 1-2

¢ “Integrating SimBiology Models into Your Existing Workflow” on page 1-6
® “Getting Started in the SimBiology Desktop” on page 1-11

¢ “Features and Functions” on page 1-16

* “SimBiology Support and SBML” on page 1-26

¢ “SimBiology Model Components” on page 1-29
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Product Overview

In this section...

“Integrated Environment” on page 1-2
“Expected Users” on page 1-3
“Required Software” on page 1-4
“Optional Software” on page 1-4
“Related Software” on page 1-5

Integrated Environment

SimBiology software provides an integrated environment for modeling
biological processes, simulating the dynamic behavior of these processes,
and analyzing the model with simulation and experimental data. Biological
processes include metabolic, genetic, and signaling pathways with transform,
binding, and transport reactions.

You can also create and analyze pharmacokinetic models. For more
information see “Pharmacokinetic Modeling” in the SimBiology User’s Guide.

® Model — Design and build models by entering reactions, species,

parameters, kinetic laws, rules, and events with a graphical user interface,
a block diagram editor, or using the MATLAB® Command Window. Verify
that the model can be simulated, and use the verification results to fix
any incompatibilities in the model.

Import SBML models created with the SimBiology software or other
modeling software that is compliant with the Systems Biology Markup
Language (SBML) standard.

Export models created with the SimBiology desktop to MATLAB and
continue your simulations and analysis with command-line functions. For
more information, see “Modeling” on page 1-23.

¢ Simulate — Observe changes in species amounts and parameter values

over time. Convert your model to a system of differential equations and
simulate the model numerically with various differential equation solvers.
The deterministic solvers include stiff and nonstiff ordinary differential
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equation (ODE) solvers. The stochastic solvers include a stochastic
simulation algorithm with implicit and explicit tau variations. Perform
multiple stochastic ensemble runs. For more information, see “Simulation”
on page 1-23.

® Analyze — Save data from a simulation, compare simulation and
experimental data, perform sensitivity analysis, species or parameter
scans, parameter estimation, and search for conserved moieties. For more
information, see “Analysis” on page 1-24.

Expected Users

The people who use SimBiology software come from a wide range of areas
including biology, systems biology, pharmacology, computer science, and
engineering. This product is intended for research scientists, computational
biologists, and students who need to develop and study biological pathways
at the molecular and systems level, develop custom analysis applications, or
implement published ones, and visualize results.

Industry and Professional — SimBiology software allows you to model,
simulate, and analyze biochemical and system pathways for applications
in drug discovery and design, target identification, and pharmacokinetic
modeling.

Modeling, simulating, and analyzing a biological system can test hypotheses
for a pathway, identify side effects caused by drug interactions with a target
compound, and identify biochemical pathways that lead to disease.

Academia — Build rigorous, dynamic, quantitative models that allow you to
understand and predict system behavior at the molecular level. Build models
to explore enzyme kinetics. Leverage the MATLAB foundation to easily
manipulate large data sets.

Simulating the dynamic behavior of a model can confirm the validity of the
models and identify behaviors and control mechanisms not apparent from
studying static models. Validate models experimentally and use the model to
predict in vitro and in vivo behavior.

1-3
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Required Software

To use SimBiology software, you must first install the following product from
the MathWorks™:

MATLAB Provides a command-line interface and
an integrated software environment. For
instructions, see the MATLAB installation
documentation for your platform.

If you have installed MATLAB and want
to check which other MathWorks products
are installed, enter ver in the MATLAB
Command Window.

Optional Software

Statistics Toolbox™ (Version Provides fitting tools including functions

7.0 (R2008b) or greater) - used to analyze non-linear mixed effects.
This toolbox is required for analyzing
non-linear mixed effects.

Genetic Algorithm and Solve optimization problems using genetic

Direct Search Toolbox™ and direct search algorithms. If this
toolbox is installed, you can use various
genetic and direct search algorithms for
parameter estimation. If this toolbox
1s not installed, the software uses the
optimization algorithms available in
MATLAB.

Optimization Toolbox™ Optimization Toolbox extends the
MATLAB technical computing
environment with tools and widely used
algorithms for standard and large-scale
optimization. These algorithms solve
constrained and unconstrained continuous
and discrete problems. If the Optimization
Toolbox product is installed, you can use
some algorithms included this product
for parameter estimation in SimBiology
software. If the Optimization Toolbox
product is not installed, the software uses

1-4 the optimization algorithms available in
MATLAB.



Product Overview

Related Software

Bioinformatics Toolbox™ Read, analyze, and visualize genomic,
proteomic, and microarray data.
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Integrating SimBiology Models into Your Existing
Workflow

In this section...

“Existing Workflow in Experimental Research” on page 1-6
“Workflow Incorporating Mathematical Modeling” on page 1-7

“Workflow Using SimBiology Models for Mathematical Modeling” on page
1-9

Existing Workflow in Experimental Research

Consider the following typical workflow in research. The subsequent figure
shows these general steps in experimental research.

1 Use preliminary results and published data to develop a model and
hypothesis in your area of interest.

2 Validate your model by making predictions and designing experiments
to test your model and hypothesis.

3 Make further predictions based on your model.
4 Publish results and predictions.

5 Continue to test predictions experimentally.

1-6



Integrating SimBiology® Models into Your Existing Workflow
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Typical Workflow in Experimental Research

Workflow Incorporating Mathematical Modeling

Mathematical modeling integrates into the preceding workflow by providing
the means to:

¢ Consolidate quantitative data into the model.

® Represent large pathways and networks and lay them out in meaningful
ways using a software application.

e Study emergent properties of pathways and use these predictions to guide
the direction of experimental research in ways that can save time and
development costs.
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Integrating SimBiology® Models into Your Existing Workflow

Workflow Using SimBiology Models for Mathematical
Modeling

The SimBiology software provides an integrated environment for
mathematical modeling and analysis of biological and biochemical pathways.
The following diagram shows you an overlay of features and tasks in the
product pictured in the context of the complete workflow in experimental
research.
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Getting Started in the SimBiology® Desktop

Getting Started in the SimBiology Desktop

In this section...

“Overview” on page 1-11

“Creating or Opening a Model Using the New Project Wizard” on page 1-11

“Opening a SimBiology Project” on page 1-15

Overview

Depending on your application area and the extent of the existing knowledge
base for your area of interest and ease of data availability, you might choose
various different paths into, within, and out of the product. For example:

¢ Build the model using SimBiology software; use published or unpublished
kinetic data that you directly enter into the product or import the kinetic
data using Microsoft® Excel® or text files, and then perform simulation
and analysis.

¢ Build a pharmacokinetic model using the New Project Wizard, and analyze
the model.

® Open and work with a SimBiology model (project) that you have obtained.

® Import an SBML format model into the product and perform simulation
and analysis.

Creating or Opening a Model Using the New Project
Wizard

The New Project Wizard lets you import data, add a model, and select the
analysis tasks you want to add to the model:

1 In the MATLAB Command Window, type:

simbiology

The SimBiology desktop opens.

2 Select File > New Project. The New Project Wizard opens.

1-11
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3 Choose to add data using the Add Data pane, or click Next. To add data:

a In the Add Data pane, from the Source list, select File or MATLAB
Workspace.

b Depending on the selection in the previous step, specify the name of the
file or the MATLAB variables to import and click Next.

4 In the Add Model pane, from the Select a model to add list, select one
of the following:

Model Selection Description

Create a new blank model Creates a model containing

one compartment (at least one
compartment is required for all
models). You can later add model
components such as species,
reactions, rules, and events to the
model.

Create a PK Model Automatically generates
pharmacokinetic (PK) models

by specifying compartment
number, dosing type, and method
of elimination.

Load model from file Open a model from another project,
or open an SBML model.

Import model from MATLAB Imports a model already in the

workspace MATLAB workspace.

Do not add a model Lets you work with imported data

without adding a Model Session .

1-12
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) New Project Wizard x|

Steps | Add Madel

1. Add data

Select a model ko add:

2, Add model
3. Choose analysis

I Create new blank madel

Create new blank madel
Create PK model

Load model From File
Import modzl From MATLAB workspace
Do not add a model

< Back

Cancel

Mext = Finish

5 Depending on the selection in the previous step, do one of the following:

If you chose ...

Do the following ...

Create a new blank model

(Optional, but recommended) In
the Model Name box enter a name
for the model.

Create a PK Model

Specify compartment number,
dosing type, and method of
elimination. For more information
see, “Creating PK Models in the
SimBiology Desktop Using a
Wizard” in the SimBiology User’s
Guide.

Load model from file

Browse to, or specify the name of
the project or SBML file.

Import model from MATLAB
workspace

Select from a list containing models
from the workspace.

Do not add a model

Go to the next step.

6 Click Next.
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7 In the Choose Analysis pane, select the analysis tasks to add to the model
and click Finish.

A new project with the selected specifications opens.

1-14
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Opening a SimBiology Project

To open a SimBiology project that you received:
1 In the MATLAB Command Window, type:
simbiology
The SimBiology desktop opens.

2 Select File > Open Project to open the Open SimBiology Project dialog
box.

3 Browse to and select the .sbproj format file containing the project.

1-15
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Features and Functions

In this section...

“Using the Command Line versus the SimBiology Desktop” on page 1-16
“Graphical User Interface” on page 1-17

“Command-Line Interface” on page 1-21

“Data Formats and Projects” on page 1-22

“Modeling” on page 1-23

“Simulation” on page 1-23

“Analysis” on page 1-24

Using the Command Line versus the SimBiology
Desktop

SimBiology extends MATLAB and lets you access functionality at the
MATLAB command line and the graphical SimBiology desktop.

Use the MATLAB command line to write and save scripts for batch processing,
to automate your workflow, and to do parallel computing.

Use the SimBiology desktop to interactively change and iterate through the
model workflow. The SimBiology desktop also lets you encapsulate models,
data, tasks, task settings, and diagnostic plots into one convenient package,
namely a SimBiology project.

Further, if you are using the SimBiology desktop and want to learn about
working at the command line the M-code capture feature in the desktop lets
you visualize the commands and export M-files for further scripting in the
MATLAB editor.

Two tutorials in the Getting Started Guide walk you through building models
through the desktop:

e “Modeling Using the SimBiology Graphical User Interface” on page 2-8
¢ “Modeling Using the SimBiology Diagram” on page 2-16
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Another tutorial in the Getting Started Guide walks you through building
models at the command line:

® “Modeling Using the Command-Line Interface” on page 2-39

If you want to learn about pharmacokinetic modeling features see
“Pharmacokinetic Modeling”.

There are video demos that show you how to work in the desktop and M-file
demos that show you how to programmatically build a model, simulate, and
analyze. To access SimBiology demos, type the following at the MATLAB
command line:

demo matlab simbiology

Graphical User Interface

The SimBiology desktop provides access to command-line functionality
through a graphical user interface. The interface lets you model, simulate,
and analyze biological pathways and reactions. Export your model to the
MATLAB workspace and perform further analysis using the command line.

1-17
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The graphical user interface (SimBiology desktop) is organized with the
following set of integrated tools:

* Project Explorer — View projects and the organization of models, and
navigate to components and subcomponents using a hierarchical tree view.
The project branch is divided into separate model sessions.

Diagram — Enter model data using block representations for species,

and reactions. Use the Plot block to visualize simulation data during a
simulation.

Block Library Browser — View and use blocks from the built-in

Basic library, and add custom blocks to user-defined block libraries for
use in the diagram.

Alignment Tool — Align blocks in a diagram.

e Table View of Model Components — Enter data for model components
such as reactions, species, or parameters, using a familiar spreadsheet
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format, forms, comma-separated files, or previously saved SBML models.
Model and simulate biological processes as reactions with reactants,
products, and reaction rates. Reactions include processes that transform
species, and processes such as transport, and binding.

Verify Models — Verify that the model does not generate any warnings or
errors that would prevent simulation or analysis.

Simulation — Simulate a model with deterministic or stochastic solvers,
save simulation data, and export data to the MATLAB workspace.

Analysis Tasks — Calculate sensitivities, scan species or parameters, fit
parameters (analyze nonlinear mixed effects), find conserved moieties,
perform ensemble simulations, or create custom analysis tasks.

Plotting — Generate plots to visualize simulation and analysis results,
and create and save custom plots.

Block Library Browser — Use the Basic library for blocks in the diagram.

Diagram Overview — Pan through large models using the miniaturized
view of the model in this tool.

Diagram Table View — Tools like hiding, pinning, splitting, and cloning
for model layout in the Diagram, and generate a histogram for degree of
connectivity of species in a model.

Searches — Create custom searches for object properties with specific
values within a project.

Find — Use the Find feature for simple searches within a project. The
results are shown in the Search Results pane.

Generate Reports — Create reports for your project, include diagrams,
figures, and data in the reports, and save them as HTML files.

Kinetic Law Manager — View built-in kinetic laws and define your own
kinetic laws.

Unit Manager — View built-in units or define your own units composed
from basic physical quantities.

Table Column Manager — Customize the desktop spreadsheets using
the Table Column Manager to display or hide the properties you are
interested in viewing or editing.

1-19
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® M-code capture — Convert interactive GUI actions with the SimBiology
desktop to M-code scripts, and load them into MATLAB.

¢ Embedded help — The embedded help pane is context sensitive to the
tasks you are performing while you build, simulate and analyze your
model. As you select component branches in the Project Explorer pane or
optional panes, the topics that support your current tasks appear in the
embedded help pane on the right.

The Help browser supplements the embedded help information with
detailed reference material for command-line functions; object methods
and properties; tutorials to help you get started; and more details about
modeling, simulation, and analysis.

Customizing Desktop Views and Preferences
You can arrange the desktop layout according to your preferences.

¢ Changing preferences — Select File > Preferences to open the
SimBiology Preferences dialog box. You can change preferences for the
following:

Desktop Display — Specify which toolbars to display and which
properties to display in model component tables.

Project Explorer — Specify whether to double-click or single-click to
open each pane from the Project Explorer.

Diagram — Specify Indicator options, and whether to always warn
when there are disallowed block actions.

Search — Specify whether double-clicking a search result should open
the selected component in the table view or the diagram.

Report Generator — Specify the default format for report output,
stylesheet to use when generating the report, default image formats,
size, and location.

History — Specify the number of recently used models, projects, help
queries, searches, and libraries to display.

Confirmation Dialogs — Specify whether dialog boxes should open for
confirmation of various deletions, parameter reordering, or defining
undefined variables.

1-20
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Changing pane location — Click the title bar of a pane, drag it to the
desired location, and drop. The diagram shows you an outline of the pane
during drag and drop. If the dropped location is on top of another pane,
click the tabs at the bottom to navigate between the panes.

Obtaining default layout — From the Desktop menu, select Desktop
Layout and select Default Layout.

Organizing tables — You can also add or delete the properties listed in
the table columns on each pane using the Table Column Manager.

If the Table Column Manager does not appear on your SimBiology
desktop, from the Desktop menu, select Table Column Manager. The
Table Column Manager opens in the desktop, and if the context-sensitive
help pane is open, the help updates with more information.

Changing pane title bar position — You can open multiple panes from
the Project Explorer. Each pane has a title bar in the Project Settings
pane. You can change the location of the title bar. Right-click the title bar
and then select Alphabetize or select Bar Position and select the location.

Project Settings - My ProjectModel Session - untitled

J MY Project " II Mol Caccimm editladd " I

. X Close My Project Chrl4+
H Save é
Alphabetize

m Mowve My Project On Bar 4 i

. Bokkonn
Model Ohrerview  [Wiew Diagram)

Right
Tvpe Count Left
Species a Hide

Command-Line Interface

You can access all features interactively from the MATLAB Command
Window or programmatically using M-code scripts.

You can either create your models in the SimBiology desktop and export to
the workspace or create your models directly in MATLAB.

¢ Functions — Use functions to create projects, manage the unit and kinetic

law libraries, and simulate and analyze models.

1-21



Introduction

1-22

® Methods — Use methods to create objects and specify object property
values.

¢ M-code capture — In the SimBiology desktop, you can record and save
your actions as an M-code script. After loading the script into MATLAB,
you can then run the script programmatically and observe what you
created interactively.

Data Formats and Projects

Store your models in project files. Projects group related models and
simulation data into project files.

* Projects — Organize projects with related models, simulation data, and
analysis results.

A project combines models, simulations, analysis, and results. Each project
1s divided into one or more model sessions.

® Model session — In the SimBiology desktop, a project can contain one
or more model sessions. Each model session contains a model, all its
configuration settings, and any saved data.

The configuration settings include simulation settings, units, kinetic laws,
tags, notes, and annotations.

¢ Kinetic Law library — Use built-in kinetic laws or create your own
kinetic laws for defining reaction rates.

® Units library — Use built-in units or create your own units for species
and parameters.

In addition, SimBiology software supports SBML Level 2 Version 1. Systems
Biology Markup Language (SBML) is becoming the standard language for
documenting and sharing mathematical models for biological systems. You
can save your models to an SBML-formatted file or read an SBML file created
with SimBiology or other modeling software. For more information, see
“SimBiology Support and SBML” on page 1-26.

When you save a project, the model definition is saved with the project.
However, you can independently export a SimBiology model to an SBML
file. Use this SBML file to import your model into SBML Level 2 Version
1-compliant modeling and simulation software.
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When you import an SBML file created with other software, the model
definition is translated into SimBiology objects.

Modeling

You can use SimBiology software to design and build pathway models.

® Model — A SimBiology model is a collection of interrelated reactions,
rules, and events that transform, transport, and bind species. The model
components are compartments, species, reactions, parameters, rules, and
events. After creating a model, add a compartment. Then you can add
reactions to the model, define a kinetic law for each reaction, and add the
parameters for the reaction.

® Model properties — Properties define the characteristics of a component.
For example, a reaction includes properties for reactions such as reaction
rates, and links to associated species, parameters, and kinetic laws. You
can interactively change these properties in the graphical user interface.

At the command line, all model components are represented as objects.
Use the get and set commands to list object properties and change their
values at the command line.

* Notes — The Notes property allows HTML-formatted text. This property
lets you link to journal articles in PDF and other formats, Web pages,
databases, graphic files, experimental data, and verbose project notes that
do not fit into a text box.

Simulation
SimBiology software includes both stochastic and deterministic solvers.

® Stochastic simulation — Genetic and signaling pathways often have
a small number of molecules that are simulated more accurately with
stochastic algorithms. The stochastic solvers are based on Daniel
Gillespie’s exact solution algorithm with variations for implicit and explicit
tau leaping.

Gillespie, D., (1977), “Exact Stochastic Simulation of Coupled Chemical
Reactions,” The Journal of Physical Chemistry, 8(1):2340-2361.

The implicit tau-leaping solver works optimally with large, numerically
stiff systems. When solving numerically stiff systems, this solver remains
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stable for large time intervals (tau) where the explicit tau-leaping solver
might not.

While stochastic simulations might accurately reflect the actual processes
in a cell, they might not be practical for models with a large number of
reactions or higher species amounts. Metabolic and signaling transduction
pathways fall into this category. In this case, mass-action kinetics and
ODE solvers can be a reasonable approximation.

¢ Deterministic simulation — You can choose from the list of stiff and
nonstiff deterministic simulation solvers that are included with MATLAB.
These solvers are reliable and robust.

¢ Dimensional analysis and unit conversion — Dimensional analysis
compares the physical quantities for parameters and species in
mathematical expressions (reaction rates, algebraic rules, assignment
rules, and rate rules) and verifies that they are in consistent dimensions.
Unit conversion scales the parameter values and species amounts to have
the same units before simulation.

* Plotting simulation results — At the end of the simulation, the software
plots the results in a figure window, or you can change plot settings and
replot selected species yourself. In the SimBiology desktop, insert and
configure a Plot block in the Diagram pane to view the results in a plot
while the simulation runs.

¢ Simulations settings — Configuration set objects define the properties
needed for simulation. These properties include the simulation time,
absolute and relative tolerances, and controls for dimensional analysis
and unit conversion.

Analysis
SimBiology software is closely integrated with MATLAB.

® (Getting simulation data into MATLAB — During a simulation, the
software saves (logs) the values for parameters and the amounts of species
to the MATLAB workspace.

¢ Plotting simulation data and analyzing results — Using the functions
in MATLAB, you can select and scale species for plotting.

* Parameter estimation and optimization — Estimate parameters that
are unknown in the model.
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Features and Functions

® Sensitivity analysis — Calculate sensitivities of species with respect to
species and parameter input factors.

* Moiety conservation — Calculate a complete set of linear conservation
relations for the species in a SimBiology model.

¢ Ensemble runs — Perform iterative simulation runs to compare and
analyze simulation results from stochastic solvers. Find the mean and
variance as a function of time.
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SimBiology Support and SBML

In this section...

“What Is SBML?” on page 1-26
“SBML Support” on page 1-26
“Importing SBML Files” on page 1-27

“Converting a SimBiology Model to SBML Format” on page 1-27

What Is SBML?

Systems Biology Markup Language (SBML) is an information standard for
sharing, evaluating, and developing systems biology models cooperatively.

Its purpose is to provide a structure for creating models and sharing those
models among various modeling and simulation software tools. The current
specification is available on the Web at http://sbml.org/documents/.

SBML Support

SimBiology software supports a subset of the SBML Level 2 Version 1
specification. You can import from and export to SBML-compatible .xml files.

Unsupported features include:

® Piecewise kinetics — Models with piecewise kinetics are loaded in, but the
definitions for piecewise kinetics are ignored.

¢ Function definitions — Models containing functional definitions are loaded,
and you see a warning and the function definitions are ignored.

e MATLAB incompatible variable names in UnitDefinition — Models that
have variable names incompatible with MATLAB in UnitDefinition are
not loaded and you see an error message.

® The hasOnlySubstanceUnits field does not have a corresponding property
in the SimBiology species object. For more information on dimensions for
SimBiology species, see DefaultSpeciesDimension.
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SimBiology® Support and SBML

Importing SBML Files

To import an SBML file in the SimBiology desktop, use the New Project
Wizard.

1 In the MATLAB Command Window, type:

simbiology

The SimBiology desktop opens.
2 Select File > New Project. The New Project Wizard opens.
3 Choose to add data using the Add Data pane, or click Next.

4 In the Add Model pane, from the Select a model to add list, select Load
model from file

5 Browse to, or specify the name of the project or SBML file.
6 Click Next.

7 In the Choose Analysis pane, select the analysis tasks to add to the model
and click Finish.

A new project with the selected specifications opens.

Converting a SimBiology Model to SBML Format

To convert a SimBiology model to SBML format,

1 Select File > Export Model to SBML. The Save Systems Biology Markup
Language File (SBML) dialog box opens.

2 Enter a path and file name.

3 Click Save.
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The following information is included in the saved SBML format file:

e Compartments, events, parameters, reactions, rules, and species that are
defined in the model.

Note Rules, reactions, and events that have their Active property set to
false (inactive) are not exported.

e All unit definitions in SBML-compliant form

® The reaction rate equation, but not the kinetic law definition
Example

In SimBiology kinetic laws, the Henri-Michaelis-Menten equation,
V,*S/ (K, +S) is a kinetic law definition stored in the kinetic law library.

Specifically, for a one-substrate enzyme-catalyzed reaction, if you assign
V,=V,, K=K, and S = A, the reaction rate equation is V_*S/ (K +A)

m a’ m

e Model component properties with SBML equivalents, such as Annotation,
species, and parameter unit values will be exported. Features and
properties specific to SimBiology software, such as Tag and Active, cannot
be exported.

The following SimBiology features are not supported by SBML and not
included in the saved SBML format file:

® Projects — SimBiology software creates and stores all your models in
project files with the .sbproj extension. You can store multiple models in
one project file.

® Kinetic law — You can store kinetic law information such as the kinetic
law name and a kinetic law definition.



SimBiology® Model Components

SimBiology Model Components

In this section...

“Organization of SimBiology Objects” on page 1-29
“Model” on page 1-30

“Compartment” on page 1-30

“Species” on page 1-31

“Reaction” on page 1-31

“Kinetic Law” on page 1-32

“Parameters” on page 1-33

“Rules” on page 1-33

“Events” on page 1-35

“Configuration Sets” on page 1-35

“Variants” on page 1-36

“Simulation Data” on page 1-36

Organization of SimBiology Objects

If you plan to work mainly from the SimBiology desktop GUI, you can

skip this section and go to “Model” on page 1-30. The GUI allows you to
interactively work with SimBiology model components without having prior
knowledge of object-oriented programming, or the object implementation
thereof in the software product.

If you plan on using the product at the command line, it is useful understand
the hierarchical organization of SimBiology objects.

SimBiology objects are organized as a hierarchical list of objects under one
root object.

Models and each model component are represented as objects. Further, there

are objects to store simulation settings (configset object) and data from
simulation and analysis tasks (data object)
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Models must contain at least one species object and one compartment object.
The hierarchy of objects in models is as follows:

Model

Compartment
Species

Parameters

Reaction
Kinetic Law

Parameters

Rules

Events

Variant

Configset

SimData

Parameters can be scoped to a kinetic law or the model.

The recommended method to store your SimBiology models is to create and
store project files.

Model

A SimBiology model is a collection of interrelated reactions, rules, and
events that transform, transport, and bind species. The model components
are compartments, species, reactions, parameters, rules, and events. After
creating a model, add a compartment, then you can add reactions to the model,
define a kinetic law for each reaction, and add the parameters for the reaction.

Properties define the characteristics of an object. For example, a reaction
object includes properties for reactions, reaction rates, and links to associated
species, parameters, and kinetic laws. You can interactively change object
properties in the graphical user interface. Use the get and set commands to
list object properties and change their values at the command line.

Compartment

A compartment allows you to associate pools of species to physically isolated
regions.
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Since compartments define physically isolated regions, species are assigned
to compartments. Reactions, rules, events, and parameters are assigned to
the model.

All models must have at least one compartment and all species in a model
must be assigned to a compartment. You can create a compartment within
another compartment, but compartment names must be unique within a
model. For information on specifying names of compartments, see Name in the
SimBiology Reference documentation.

Species

A species 1s a chemical or entity that participates in reactions, for example,
DNA, ATP, Pi, creatine, G-Protein, or Mitogen-Activated Protein Kinase
(MAPK). Species amounts can vary or remain constant during a simulation.

For information on specifying names of species, see Name in the SimBiology
Reference documentation.

Reaction

A reaction describes a transformation, transport, or binding process that
changes one or more species. Typically, the change is the amount of a species.

Examples:

Creatine + ATP <-> ADP + phophocreatine

glucose + 2 ADP + 2 Pi -> 2 lactic acid + 2 ATP + 2 H20
cytoplasm.A -> nucleus.A

[compartment 1].[species A] -> [compartment 2].[species A]

Spaces are required before and after species names and stoichiometric values.
Stoichiometry values must be greater than zero. If the stoichiometry value is
not specified it is assumed to be 1. In a model with a single compartment, the
species 1s specified using its name. In a model with multiple compartments,
the species must be specified as compartmentName.speciesName. Enclose
names with non-alphanumeric characters in brackets.
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Kinetic Law

A Fkinetic law provides a mechanism for applying a specific rate law to
multiple reactions. It acts as a template for the reaction rate. The kinetic
law is defined by an expression, and the species and parameter variables
used in the expression.

The ReactionRate is the result of defining the names of parameters and
species variables in a rate law. To get ReactionRate, the species variables
and parameter variables that participate in the reaction rate should be clearly
assigned in the Project Settings-Reactions pane on the Kinetic Law tab.

For example, the kinetic law Henri-Michaelis-Menten is expressed in the
software as

Vi *SIK,, +S)
where Vm and Km are defined as parameters and S is defined as a species. (To

see parameter and species definitions for a kinetic law, access the Kinetic
Law Manager from the Desktop menu.)

By applying the kinetic law Henri-Michaelis-Menten to a reaction
A ->B

with Vm = Va and Km = Ka
and S = A

the rate equation 1s

Va*A/(Ka + A)

A, Va, and Ka are defined in the Kinetic Law tab.

Reaction Rate Equation

The reaction rate equation is a mathematical expression that describes the
rate at which the reactants combine to form products.

For a reaction following Mass Action kinetics,

Creatine + ATP <-> ADP + phophocreatine



SimBiology® Model Components

the rate equation is written as

K*Creatine*ATP - Krev*phosphocreatine*ADP

Parameters

A parameter is a quantity that can change or can be constant. Parameters are
generally used to define rate constants. But, you could also use parameters as
constants to modify model component values in rules and events.

For information on specifying names of parameters see Name in the SimBiology
Reference documentation.

Scope refers to the definition of a parameter at the model (global) level or
kinetic law (local) level.

If the scope of the parameter is global in the model, it can be used by any rule,
event, or by any reaction rate in the model. If the scope of the parameter is at
the kinetic law level, it can be used only by the kinetic law in the reaction for
which it was defined.

How to Use Scope

For reaction rate, SimBiology hierarchically uses the value of the parameter
with scope at the kinetic law level first. If there is no such parameter at
the kinetic law level, SimBiology looks for the parameter with scope at the
model level.

If there are two parameters with the same name, one at the model level and
the other at the kinetic law level, the software uses the value of the parameter
at the kinetic law level for the reaction rate. The software uses the value of
the parameter at the model level for any rules or events that reference the
parameter.

Rules

A rule 1s a mathematical expression that modifies a species amount,
compartment capacity, or a parameter value. There are four types of
SimBiology rules:
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algebraic — Algebraic rules are evaluated continuously during a
simulation. An algebraic rule takes the form 0 = Expression and the
rule is specified as the Expression. For example, you could write a mass
conservation expression such as species_total = species1 + species2
where species_total is the independent variable, write the rule as

species1 + species2 - species_total

initialAssignment — initialAssignment rules are evaluated

once at the beginning of a simulation. initialAssignment rules are
expressed as Variable = Expression. For example, you could write an
initialAssignment rule to set the amount of species1 to be proportional
to species2.

species1 = k/species2

repeatedAssignment — repeatedAssignment rules are evaluated at every
time-step during a simulation. repeatedAssignment rules are expressed
as Variable = Expression. For example, you could use the rule to specify
the amount of speciesi to always be proportional to species2.

species1 = k/species2

Rate — Rate rules are evaluated continuously during a simulation. Rate
rules are determined by dVariable/dt = Expression, which is expressed
in the software as Variable = Expression. For example, to define the
rate of change in the quantity of species3 (dspecies3/dt), write the rule
in the software as:

species3 = k * (speciesl1 + species2)

One example of a rate rule is when Species1 is at the boundary of the
system, but the rate of input of species to the system can be determined
by a rate rule.

Tip If you plan to use a parameter in a rule, remember to set the Scope
of the parameter to model. Further, if you are using an algebraic or rate
rule to vary the value of a parameter during the simulation, clear the
ConstantValue check box for the parameter in the Parameters pane,
Settings tab.
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For more information, see “Changing Model Component Values Using Rules”
in the SimBiology User’s Guide.

Events

Events are used to describe sudden changes in model behavior. An event lets
you specify discrete transitions in model component values that occur when a
user-specified condition become true. You can specify that the event occurs at
a particular time, or specify a time-independent condition. For example, you
can use events to activate or deactivate certain species (activator or inhibitor
species), change parameter values, change reaction rates in response to
addition or removal of species. For more information about events, evaluation
of events, and examples, see “Changing Model Component Values Using
Events” in the SimBiology User’s Guide.

Configuration Sets

Configuration sets contain the options that the solver uses during simulation
of a model. To add, view or edit configuration sets associated with a model,
in the Project Explorer expand Model Variable Settings and click
Configuration Settings. The configuration set contains the following
options for you to choose:

® Type of solver

¢ Data to record (Data Logging tab)

e Stop time for the simulation

® Solver error tolerances, and for ode solvers — the maximum time step the
solver should take

® Whether to perform sensitivity analysis during simulation

® Whether to perform dimensional analysis and unit conversion during
simulation

® Species and parameter input and output factors for sensitivity analysis

For more information see “Performing Simulations” in the SimBiology User’s
Guide.
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Variants

Variants let you store the names and values of model components and allow
you to use the values stored in the variant as the alternate value to be
applied during a simulation. To add, view or edit variants associated with
a model, in the Project Explorer expand Model Variable Settings and
click Variants. You can store values for species InitialAmount, parameter
Value, and compartment Capacity, in variants.

Using one or more variants associated with a model allows you to evaluate
model behavior during simulation, with different values for the various model
components without having to search and replace these values, or having to
create additional models with these values. If you determine that the values
in a variant accurately define your model, you can permanently replace the
values in your model with the values stored in the variant object by clicking
Commit.

For more information see “Storing and Applying Alternate Model Values
Using Variants”in the SimBiology User’s Guide.

Simulation Data

The SimBiology SimData object contains simulation data. The SimData object
holds time and state data as well as metadata, such as the types and names
for the logged states, or the configuration set used during simulation. For
more information see SimData object.



Building SimBiology Models

® “Gene Regulation Model” on page 2-2

¢ “Modeling Using the SimBiology Graphical User Interface” on page 2-8
e “Modeling Using the SimBiology Diagram” on page 2-16

® “Modeling Using the Command-Line Interface” on page 2-39
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Gene Regulation Model

In this section...

“Model Diagram” on page 2-2
“Model Reactions” on page 2-3

“Opening the Gene Regulation Model in the SimBiology Desktop” on page
2-6

Model Diagram

You can visualize a systems biology model with various levels of detail. One
view sketches only the major species and processes. This model is an example
of simple gene regulation, where the protein product from translation controls
transcription. You could create a more complex model by adding the enzymes,
coenzymes, cofactors, nucleotides, and amino acids that are not included in
this model. The gene regulation example simplifies the regulatory mechanism
by not showing the contributions of RNA polymerase and any cofactors. The
protein product from gene expression binds to a regulatory region on the DNA
and represses transcription.

DNA

+(-) ‘
Q-ﬂ—( D

Protein mRNA

Another way of looking at a systems biology model is to list the reactions in a
model with the processes they represent.

DNA -> DNA + mRNA transcription)

(
mRNA -> mRNA + protein (translation)
DNA + protein -> DNA_protein (binding)
DNA_protein -> DNA + protein (unbinding)
mRNA -> null (degradation)
protein -> null (degradation)



Gene Regulation Model

Drawing the reaction pathways will help you visualize the relationships
between reactions and species. In the gene regulation example, as the amount
of a protein increases, the protein forms a complex with the gene responsible
for its expression, and slows down protein production.
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Model Reactions

Reaction equations define a systems biology model at the level of detail needed
for a software program to simulate the dynamic behavior of the model. The
following reactions for transcription, translation, binding, and degradation
describe a simple gene-regulating mechanism. For additional information
about this model, see “Gene Regulation Model” on page 2-2.

Transcription
Transcription is where RNApolymerase and cofactors bind with a DNA
molecule. The RNApolymerase then moves along the DNA and combines

nucleotides to create mRNA. A simple model of transcription shows only the
DNA and mRNA.

D—*
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This model simplifies the transcription and the synthesis of mRNA by using a
single reaction.

Reaction: DNA -> DNA + mRNA
Reaction rate: v = k1*DNA molecule/second
Species: DNA = 50 molecule
mRNA = 0 molecule
Parameters: k1 = 0.2 1/second

Translation

After the mRNA moves from the nucleus to the cytoplasm, it can bind with
ribosomes. The ribosomes move along the mRNA and create proteins with
the help of tRNAs bound to amino acids. A simple model of translation shows
only the mRNA and protein product.

1»

The synthesis of the protein is modeled as a single reaction.

Reaction: mRNA -> mRNA + protein
Reaction rate: v = k2*mRNA molecule/second
Species: mRNA = 0 molecule
protein = 0 molecule
Parameters: k2 = 20 1/second

Gene Repression
Transcription of DNA to mRNA is regulated by the binding of the protein
product from translation to the DNA. As more protein is produced, the DNA 1s

bound with the protein more often and less time is available for transcription
with the unbound DNA.

S (Proten
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Forward Reaction (Binding)

Reaction:
Reaction rate:
Species:

Parameters:

DNA + protein -> DNA_protein

v = k3*DNA*protein molecule/second
DNA = 50 molecule

protein = 0 molecule

k3 = 0.2 1/(molecule*second)

Notice how the units are described for the parameter k3. In the literature,
some of the common ways to display second-order rate constants are
mole'second! or 1/mole-second. However, software evaluations of these
common ways are sometimes ambiguous.

Reverse Reaction (Unbinding)

Reaction:
Reaction rate:
Species:
Parameters:

DNA_protein -> DNA + protein
k3r*DNA_protein molecule/second
DNA_protein = 0 molecule

k3r = 1 1/second

For this tutorial, model the binding and unbinding reactions as one reversible

reaction.

Reaction:
Reaction rate:
Species:

Parameters:

Degradation

DNA + protein <-> DNA_protein

v = k3*DNA*protein - k3r*DNA_protein molecule/second
DNA = 50 molecule

protein = 0 molecule

k3 = 0.2 1/(molecule*second)

k3r = 1 1/second

Protein and mRNA degradation are important reactions for regulating
gene expression. The steady-state level of these compounds is maintained
by a balance between synthesis and degradation reactions. Proteins are
hydrolyzed to amino acids with the help of proteases, and nucleic acids are
degraded to nucleotides.

mRNA

00
o
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mRNA degradation is modeled as a transformation to the null species.

Reaction: mRNA -> null
Reaction rate: v = k4*mRNA molecule/second
Species: mRNA = 0 molecule
Parameters: k4 = 1.5 1/second

Likewise, protein degradation is also modeled as a transformation to the null
species. The species null is a predefined species name in SimBiology models.

(Protein) >

Reaction: protein -> null
Reaction rate: v = k5*protein molecule/second
Species: protein = 0.0 molecule
Parameters: k5 = 1.0 1/second

Opening the Gene Regulation Model in the
SimBiology Desktop

A project containing the model built in the gene regulation example is
available with the product. To skip the sections on model building and
to learn about simulations in the SimBiology desktop, you can access the
completed model in the SimBiology desktop.

1 In the MATLAB Command Window, type:

simbiology

The SimBiology desktop opens.

2 Select File > Open Project to open the Open SimBiology Project dialog
box.

3 Navigate to:

matlabroot/toolbox/simbio/simbiodemos

4 Select gene_reg.sbproj, and click Open.



Gene Regulation Model

The project opens with two models: cell and cell2. These two models
are 1dentical except for the graphical representation of the blocks in the
Diagram pane.

5 To explore the models, click an item in the Project Explorer to open
individual panes.

6 See “Simulating a Model” on page 2-15 for procedures on simulating a
model in the SimBiology desktop.
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Modeling Using the SimBiology Graphical User Interface

In this section...
“About the Model Used in This Tutorial” on page 2-8

“Creating a Model” on page 2-8
“Saving Your Work as a SimBiology Project File” on page 2-9
“Adding Reactions to a Model” on page 2-10

“Simulating a Model” on page 2-15

About the Model Used in This Tutorial

This section shows how to mathematically model a simple gene-regulation
pathway using the SimBiology desktop. The example uses the model
described in “Gene Regulation Model” on page 2-2 and shows you how to build
this model using a spreadsheet-style interface in the SimBiology desktop.

If you prefer to interact with diagrammatic representations of pathways, see
“Modeling Using the SimBiology Diagram” on page 2-16.

Alternatively, you can use M-code and the MATLAB command-line interface
(see “Modeling Using the Command-Line Interface” on page 2-39). A
comparison of these methods will help you understand the model objects that
MATLAB creates behind the SimBiology desktop, and how to access and edit
a model through the MATLAB Command Window.

Creating a Model

A SimBiology model is a collection of objects that are structured hierarchically.
At least one model object is needed to contain all the other objects.

1 In the MATLAB Command Window, type:

simbiology

The SimBiology desktop opens.

2 Select File > New Project. The New Project Wizard opens.

2-8
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3 Skip the Add Data step for this example and select Add Model.

4 In the Add Model pane, from the Select a model to add list, select
Create a new blank model. This selection creates a Model Session
containing one compartment (at least one compartment is required for all
models). You will later add model components such as species, reactions,
rules, and events to the model.

) New Project Wizard x|

Skeps : Add Model
1. Add data Select a madel ko add:
2. Add model I Create new blank madel

3, Choose analysis -
Y Create new blank madel

Create PE model

Load madel From File

Impart model fraom MATLAE warkspace
Do not add a model

« Back Mext = Finish Cancel

5 In the Model Name box, type the name for your model.
cell

6 Click Next.

7 In the Choose Analysis pane, leave the default selection (Simulate
model) selected for the analysis tasks to add to the model and click Finish.

A new project with the selected specifications opens.

Saving Your Work as a SimBiology Project File

Project is the file format that the SimBiology software uses to save one or
more model sessions. The file extension is .sbproj. Projects let you save

2-9
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custom settings, notes, and data associated with your models. For more
information on projects, see “Data Formats and Projects” on page 1-22.

Save your work as a project now so that you can access this file later.

1 Select File > Save Project as to open the Save SimBiology Project dialog
box.

2 Browse to the folder in which you want to save your projects, and enter a
name for the project file, such as:

gene_regulation.sbproj
3 Click Save.

Adding Reactions to a Model

SimBiology models are defined by connected reactions representing
transformation, binding, and transport.

1 In the Project Explorer, expandSimBiology Model and click Reactions
to open the Reactions pane.

2 In the Enter Reaction box, enter the reactants and products, separated
by a hyphen and right angle bracket. For example, enter the following
simple reaction for transcription:

DNA -> DNA + mRNA

3 Click Add.

A red indicator appears to the right of the table (and in the Project
Explorer). Move the pointer over the indicator for the reaction to get more
information about the reason for the indicator. In this case, the indicator
shows that the reaction rate is as yet undefined. Beginning in step 5, you
will learn how to define the reaction rate.

4 Double-click the Name cell, enter a name for the reaction and press Enter.
For example, enter the following:

Transcription
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5 From the KineticLaw list, select MassAction. Your screen should
resemble this one.

Mame Reaction KineticLaw ReactionR.ate =
B Transcription DMA -= DNA + mRMA | MassAction ;l _—

P

Settings I Description

Reaction: [~ Reversible

[DMA - DNA + mRNA an
KineticLaw: Expressian:
I MasshAction d I(Forward Rate Parameter)*(Masshction Species)
+ Map bebween KineticLaw Parameters and Paramater Names:
Kinetic Law Parameter Parameter Name | Valus Scope ValusUnits | ¥
jBll| Forward Rate Parameker ;l ;l gjx

/ Map bebween KineticLaw Species and Species Names:

Kingtic Law Species | Species Mame Initial&mount Scope Initial&mount. ..
il MassAction Species | DMA 0.0 unnamed ;l

[_IReactionRate: (ReactionRate not Fully defined, Map parameters and species above to define,)
Mame:
ITranscriptinn

¥ Active (Select if the reaction is enabled during the simulation.)

Note Species names are automatically populated for Mass Action. In this
example notice that MassAction Species lists DNA.

6 In the Map between KineticLaw Parameters and Parameter Names
section, locate the Forward Rate Parameter row, double-click the
Parameter Name cell, type k1 and press Enter.

The SimBiology desktop updates ReactionRate for the reaction to show
k1*DNA.

Your reaction table should resemble the following.
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Marme Reaction KineticLaw: ReactionRate
Tranzcription | DRA -= DRA + mRRNA | Massfction ;I k1*DMA

The indicator is green, showing that the reaction rate is now defined. The
red indicator in the Project Explorer also disappears.

7 Double-click the Value cell and enter a new value.

0.2

8 From the ValueUnits list, select the units for this parameter. The rate

constant k1 is a first order constant with units 1/second.

Your parameters table should resemble the following.

+ Map bebween KinsticLaw Parameters and Parameter Mames:

IKinetic Law Parameter Parameter Name |Valus | Scope ValueUnits ﬁ""
1

Forward Rate Parameter ;l ki 0.2 DMNA -2 DNA + mRMA 1/second ;l

About Scope

Notice that the Scope box for the parameter lists the reaction, indicating
that the parameter is only available for reference at the level of the reaction.

If you set the scope of a parameter to the model (Model Name), you can use
this parameter in rules, other reactions, and events. All the parameters for
this example are scoped to their respective kinetic laws.

Scoping lets you overload parameters, that is you can have parameters
with the same name at the kinetic law and at the model level. Because
the desktop searches up from the kinetic law to the model level, when a
parameter is overloaded, a reaction uses the parameter and parameter
value in its kinetic law; however rules and events use the parameter value
at the model level.

A reaction uses a parameter at the model level only if a corresponding
parameter 1s not defined at the kinetic law level for the reaction.
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9

10

12

13

14

15

In the Map between KineticLaw Species and Species Names section,
locate the MassAction Species row (DNA), double-click the InitialAmount
cell, type 50 and press Enter.

From the InitialAmountUnits list, select molecule.

The Scope of the species indicates the compartment that the species is
within, and this is still unnamed. The next steps show you how to name
the compartment.

In the Project Explorer, click Compartments to open the
Compartments pane.

In the SimBiology desktop, models contain a compartment by default. The
process of adding a reaction automatically adds the reaction species to

a compartment in the model. If there are multiple compartments in the
model, you must specify the reactants and products using qualified names
(compartmentName.speciesName). For example, nucleus.DNA denotes the
species DNA in the compartment nucleus.

This example contains only one compartment. Rename the compartment
by doing the following:

In the Name cell, double-click and type a name such as contents for the
compartment and press Enter. The compartment table updates with the
new entry.

From the Capacity Units list select Liter.

Leave other compartment properties such as Owner and Capacity in the
default settings, for the purposes of this example.

In the Project Explorer, expand Compartments and click contents
Species. The species you entered in the reaction are automatically added
to the species table.

The default value for a species is 0.0.

In the row containing mRNA, from the InitialAmountUnits list, select
molecule. Leave the InititalAmounts value at 0.0.
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16 Enter the remaining reactions. For a list of reactions and parameters,
see “Model Reactions” on page 2-3.

Notice that the ValueUnits for the second-order rate constant k3 is not a
default unit in the list. However, molecule and second are default units
and you can enter this unit directly by typing the following:

1/ (molecule*second)

Your reaction, species, and parameter panes should resemble the following

ones.

Mame Reaction KinekicLaw ReactionR.ate u
Transcription DMA -= DNA + mRMNA MassAction ;l k1*DMA

Translation mRMNA -= mRMNA + protein MassAction ;l kZ*mRMA

Binding/Unbinding DMA + prokein <-= DNA_protein | MassAction ;l kI*DMA*protein - k3r*DNA_protein
mRMNA Degradation | mRMA -= null MassAction ;l ke *mP A

Protein Degradation |pratein -z null MassAction ;l kS*prakein

Mame Scope InitialAmaounkt InitialAmountUnits [

DA contents 50.0 molecule -]

mRMA cankents 0.0 malecule j

prakein conkents 0.0 malecule j

DMA_pratein contents 0.0 malzcule =]

Mame Scope Yalue Yaluelnits

k1 DA -= DA + mBMNA 0z 1/zecond ;I
k2 mREMA = mRMNA + protein 200 1/fzecond ;I
k3 DA, + protein =-= DMNA_protein 02 1A maolecule*secand) j
k3r DA, + protein =-= DA _protein 1.0 1izecond ;I
ke MR, = nul 15 1/s8cond |
kS protein -= null 1.0 1/zecand =1

For more detailed information about the reactions in this model, see “Gene
Regulation Model” on page 2-2.
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Simulating a Model

After you enter the reactions for your model, you can simulate its dynamic
behavior and plot the results.

e (Click @ (Run).

The simulation uses the default configuration settings, runs to completion,
and then plots the results in a figure window. You can annotate your plot
in the figure window. The following figure shows you an annotated version
of the plot:

Gene Regulation - ODE15s Solver
50 . . .

— DNA

mEMNA
protein
— DMA_protein

451 .

3¢ 1
30¢ 1

251 1

Species Amounts

Time {seconds)
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Modeling Using the SimBiology Diagram

In this section...

“About This Example” on page 2-16

“Creating a Model” on page 2-16

“Saving Your Work as a SimBiology Project File” on page 2-20
“Adding Reactions to a Model Diagram” on page 2-20
“Simulating a Model” on page 2-24

“Setting Block Appearance and Diagram Layout” on page 2-25

“Printing and Exporting the Diagram” on page 2-36

About This Example

This section shows how to mathematically model a simple gene-regulation
pathway using the SimBiology desktop. The example uses the model
described in “Gene Regulation Model” on page 2-2 and shows you how to build
this model using a diagram interface in the SimBiology desktop.

If you prefer to interact with a tabular representation of reaction pathways,
see “Modeling Using the SimBiology Graphical User Interface” on page 2-8.

Alternatively, you can use M-code and the MATLAB command-line interface
(see “Modeling Using the Command-Line Interface” on page 2-39). A
comparison of these methods will help you understand the model objects that
MATLAB creates behind the SimBiology desktop, and how to access and edit
a model through the MATLAB Command Window.

Creating a Model

This section shows how to model a simple gene-regulation pathway using the
SimBiology Diagram interface. For more information about this model, see
“Gene Regulation Model” on page 2-2.

A SimBiology model is a collection of objects that are structured hierarchically.
At least one model object is needed to contain all the other objects. The

2-16



Modeling Using the SimBiology® Diagram

SimBiology Diagram lets you work with the familiar graphical representation
of biological pathways and processes.

This section shows you how to build your model using block representations
for each compartment, species, and reaction. The model reactions are shown
in “Gene Regulation Model” on page 2-2.

1 In the MATLAB Command Window, type:

simbiology

The SimBiology desktop opens.

All the procedures in this section refer to the SimBiology desktop in the
default layout. To set the desktop to the default layout, select Desktop >
Desktop Layout > Default Layout.

2 Select File > New Project. The New Project Wizard opens.
3 Skip the Add Data step for this example and select Add Model.

4 In the Add Model pane, from the Select a model to add list, select
Create a new blank model. This selection creates a Model Session
containing one compartment (at least one compartment is required for all
models). You will later add model components such as species, reactions,
rules, and events to the model.
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2-18

) New Project Wizard x|

Steps | Add Madel
1. Add data Select a model ko add:

2. Add model I Create new blank madel
3. Choose analysis

Create new blank madel
Create PK model

Load model From File
Import modzl From MATLAB workspace
Do not add a model

< Back Mext = Finish Cancel

5 In the Model Name box, type the name for your model.

cell

6 Click Next.

7 In the Choose Analysis pane, leave the default selection (Simulate
model) selected for the analysis tasks to add to the model and click Finish.

A new project with the selected specifications opens.

8 In the Project Explorer, expand SimBiology Model and click Diagram
View. The Diagram pane opens.
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Project Explorer + O 2 X |'WorkArea-MyPrnject\,MndeISessinn—cell... s Q0O 2

My Prajeck

=-Model Session - cell
[—'_} SimBiology Madel
----- Diagram View
---Compartments
----- Reactions

= Events

[#}- Model Variable Settings
[ Maodel Tasks

----- External Data

----- Project Tasks

unnamed
-
3

Notice the Compartment block (unnamed) in the model. In the desktop, all
models contain a compartment by default.

1
|| Diagram View = | Maodel Session - cell = |

Select Diagram > Tools > Block Property Editor.

Tip The Block Property Editor allows you to enter or change block
properties. Select a block in the diagram to access its properties in the
Block Property Editor

All models created in the desktop contain a compartment by default. The
process of adding a reaction automatically adds the reaction species to
the compartment in the model. If there are multiple compartments in the
model, you must specify the reactants and products using qualified names
(compartmentName.speciesName). For example, nucleus.DNA denotes the
species DNA in the compartment nucleus.

Select the model’s compartment. The Block Property Editor updates to
show the compartment properties.

In the Name box, type a name such as contents for the compartment
and press Enter.
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12 From the Capacity Units list select liter.

Leave other compartment properties such as Owner and Capacity in the
default settings, for the purposes of this example.

Saving Your Work as a SimBiology Project File

Project is the file format that the software uses to save one or more model
sessions; the file extension is .sbproj. Projects let you save custom settings,
notes, and data associated with your models. For more information on
projects, see “Data Formats and Projects” on page 1-22.

Save your work as a project now so that you can access this file later.

1 Select File > Save Project as to open the Save SimBiology Project dialog
box.

2 Browse to the folder in which you want to save your projects, and enter a
name for the project file, such as:

gene_regulation.sbproj
3 Click Save.

Adding Reactions to a Model Diagram

SimBiology models are defined by connected reactions representing
transformation, binding, and transport. You can graphically represent the
reactions in the diagram. This section shows you how to add, connect, and
configure blocks in a diagram. For this example, use the ModelBuilding
block library.

1 From the Block Library Browser, click and drag a species block into
the compartment in the diagram.

2 Select the newly added species block to view the properties in the Block
Property Editor.
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| Block Property Editor - species_1 L4

* Settings

Mame:
Ispecies_l

Scope:
Icontents

InitialAmount:
jo.0

InitialAmountUnits:

| =l

[~ ConstantAmount (Select if the spacies quantity cannot change during the simulation.)

[~ BoundaryCondition (Select if the spacies quantity is not determined by the set of reactions.)

3 In the Name box, enter the species name. For this example, enter DNA.
4 In the InitialAmount cell, enter a new value.

50

5 From the InitialAmountUnits list, select the units for this species.

molecule

6 From the Block Library Browser, click and drag another species block
into the diagram. Name this species mRNA. The InitialAmount for mRNA is
the default (0.0). From the InitialAmountUnits list, select molecule as
units for this species.

7 From the Block Library Browser, click and drag a reaction block into
the diagram.

Note The newly added reaction has a red X icon, indicating the reaction
has not been fully defined. Once the reaction has been defined, as shown
later in this example, the icon should disappear.

8 Hold down the Ctrl key (Windows® and Linux® platforms) or the Option
key (Macintosh®) while clicking the DNA species block. Drag the line to the
reaction and release the mouse. The diagram assigns DNA as a reactant.
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Since DNA is also a product of the reaction, connect a line from the reaction
block to DNA. The diagram draws a dashed line, indicating that DNA is
a modifier for the reaction.

9 Draw a line from the reaction block to the mRNA species block.

10 Select the reaction block to view the block properties in the Block
Property Editor. Notice that the Reaction box shows the reaction (DNA
-> mRNA + DNA) to which the block applies.

11 In the Name box, enter a reaction name. For example, enter
Transcription.

12 From the KineticLaw list, select MassAction. The Block Property
Editor should resemble the following:

¥ Settings I;
Reaction: [~ Reversible
[Dha -> DA + mRNA an
KineticLaw: Expression:
I MassAction ;I I{F-erard Rate Parameter*{MassAction Species)
# Map bebween KinsticLaw Parameters and Parameter Mames:
Kinetic Law Parameter Parameter Name |Value Scope ValugUnits ﬁ""
iM| Forward Rate Parameter ~ | -] %
+ Map bebween KingticLaw Species and Species Names:
Kinetic Law Species | Species Mame | InitialAmount Scope Initialdmount. ..
il Masshction Species | DNA 50.0 cantents malecule ;l

[_IReactionRate: (ReactionRate not Fully defined, Map parameters and species above to define,)
Marmne:
ITranscriptinn

v Active (Select if the reaction is enabled during the simulation.)

Note Species names are automatically populated for Mass Action. In this
example notice that MassAction Species lists DNA.
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13 In the Map between KineticLaw Parameters and Parameter Names
section, locate the Forward Rate Parameter row, double-click the
Parameter Name cell, type k1 and press Enter.

The SimBiology desktop updates ReactionRate for the reaction to show
k1*DNA.

The indicator is green, showing that the reaction rate is now defined.
14 Double-click the Value cell and enter a new value.

0.2

15 From the ValueUnits list, select the units for this parameter. The rate
constant k1 is a first order constant with units 1/second.

Your parameters table should resemble the following.

+ Map bebween KinsticLaw Parameters and Parameter Mames:

IKinetic Law Parameter Parameter Name |Value | Scope ValueUnits g
1

Forward Rate Parameter ~ | ki 0.2 DA - DNA + mRMA lfsecond | g%

Your diagram should resemble this one:

|1[][]"-}.-'° vl - —— +

= Fs

ona (O

Transcription prpyA

contents
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16 Add the other species and reactions blocks, and create parameters for
each reaction as shown in the previous steps. For a list of reactions and
parameters, see “Model Reactions” on page 2-3. Verify that the reaction
rate 1s determined for each reaction.

Notice that the ValueUnits for the second-order rate constant k3 is not a
default unit in the list. However, molecule and second are default units
and you can enter this unit directly by typing the following:

1/(molecule*second)

After creating the model, the diagram should resemble this one.

!
—— —+
DHA_protein — __:C_‘_:l_
“Binding/Unbinding—
_Ffffﬂf T
_--"_F'_'—F ---\-""--.
DMA Transcription mfM A Translation pl'uteinx““xx

Protein Degradation
mRENA Degradation

conterts

Notice the use of dashed lines for species that are both reactants and
products in a reaction (modifiers). Note the indicator for a reversible reaction
associated with the Binding/Unbinding reaction.

You can change the layout and appearance of the blocks any time. Double-click
a block and click the Appearance tab to change the color, text font, size, and
location. See “Changing Block Appearance” on page 2-26 for more information.

Simulating a Model

After you enter the reactions for your model, you can simulate its dynamic
behavior and plot the results.
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Click @ (Run).

The simulation uses the default configuration settings, runs to completion,
and then plots the results in a figure window. You can annotate your plot
in the figure window. The following figure shows you an annotated version
of the plot:

Gene Regulation - ODE15s Solver
50 . . T

— DNA
45 a mRMNA
protein
40 1 | —— DNA_protein
35r .
n
S 30t .
o
E
< 25} ]
w
B
2 20 :
o
W
151 :
10r .
5 L m

U 1 1 1
0 2 4 B g

Time (seconds)

Setting Block Appearance and Diagram Layout

This section shows you how to change the appearance and layout of a
SimBiology diagram.

“Changing Block Appearance” on page 2-26

“Applying Block Appearance Styles” on page 2-28

“Changing the Diagram Layout Manually” on page 2-29
“Changing the Diagram Layout Automatically” on page 2-32

“How the SimBiology Desktop Does Diagram Layout” on page 2-35
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Changing Block Appearance

You can change the appearance of blocks, text, lines, and indicators in the
diagram. The following figure is one example.

Binding/Unbinding
DNA_protein |—= £ DNA

I
1
1
TTranscriptinn

Translation
protein |[—-——O ===
C (B

Protein Debradatiun mRMA Deéradation

This example uses the DNA species block and the Binding/Unbinding reaction
block to show you how to change the color of the blocks, the location of the

text, the appearance of the reversible indicator, and line appearance as shown
in the previous figure.

1 Select Diagram > Tools > Block Property Editor. The Block
Property Editor opens.

2 Select the species block or the reaction block to view the selected block

property in the Block Property Editor. Perform the next steps in the
Appearance section.

3 Change the following values to affect position and size of the block:

e X Position of block relative to the X axis of the diagram. For example,
for the reaction block, try 260

® Y- Position of block relative to the Y axis of the diagram. For example,
for the reaction block , try 30

¢ Width and Height— Horizontal and vertical size of the block respectively.
For example, for the reaction block, try 25 and 40 respectively
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4 From the Text Location list, select where the text should be positioned in
the diagram. The default is bottom. For example:

® For the DNA Species block, select center to position the text within the
center of the Species block.

¢ For the Binding/Unbinding Reaction block, select top.
5 From the Text Font, Block Appearance, Text Color, Edge Color, and

Face Color lists, select the text font, block appearance, text color, edge
color, and block fill color.

Tip Select Face Color > No Face Color to obtain the result shown for
reaction blocks in the diagram figure above.

Tip Select Block Appearance > Image to insert an image for the block.
The SimBiology desktop opens a dialog box that lets you browse to the

s
image location. If you change the image, click i‘ (Refresh) to reload
the updated image.

6 Double-click a line to open the Line Properties dialog box. The default line
width is 1.0 pixels. The line width in the previous example diagram is 2.0.

7 Select File > Preferences. The SimBiology Preferences dialog box opens.

8 Select Diagram.
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Diagram Preferences

Dialog options
¥ Show message dialog when an illegal block action occurs
~Indicator options
Skate Indicator Description

W  [Show indicator when a block has an error
¥  [Show indicator when a block is pinned
¥  [Show indicator when a species block has ConstantAmount set to brue
W  [Show indicator when a species block has BoundaryCondition set ko true
W  [Show indicator when a species block is cloned
[¥  |Show indicator when a reaction block has Reversible set ba true
[¥  [Show indicator when a reaction block has Active set ta False
[¥  [Show indicator when a compartment block has ConstantCapacity set to true

Apply | QK | Cancel |

9 Clear or select an indicator check box to turn off or turn on the display of
the indicator in the diagram. For example, clear the Reversible property
indicator, and click Close.

Notice that the reversible indicator is now off for the Binding/Unbinding
Reaction block in the diagram.

10 Right-click the diagram and select Layout Diagram to automatically
change the layout of the diagram. You can manually lay out the diagram
using the pin, split, clone, and hide features in the diagram.

For more information on the pin, split, clone, and hide features in the
diagram, see “Changing the Diagram Layout Manually” on page 2-29. For
information on automatic layout in the SimBiology desktop, see “Changing
the Diagram Layout Automatically” on page 2-32.

Applying Block Appearance Styles
To replicate the appearance style of a block to other blocks by copying and
applying the style on selected blocks:

1 Select a species block, for example, the DNA species block.
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2 Right-click the block and select Copy Block Style.
3 Select another block, for example, the DNA protein species block.
You can also select multiple blocks to apply the style to all selected blocks.

4 Right-click the block and select Apply Block Style. The SimBiology
desktop changes the appearance of the block to match the selected style.

Changing the Diagram Layout Manually

You can manually lay out the diagram using the pin, split, clone, and hide
features in the diagram. Use the Diagram Table View pane or a block’s
right-click context menu to change the properties discussed next. To access
Diagram Table View, select Diagram > Tools > Diagram Table View.

Tip While you are working on the diagram layout, remember to select File >
Save Project to save the desired layout of your diagram. The SimBiology
desktop saves the layout in the project.

To manually lay out the model diagram:

1 Right-click a species block, and select Split Block. For example, split
the protein Species block.

The SimBiology desktop provides a representation of the split block for
each instance of the species in the model. Notice that although there could
be multiple split blocks, there is only one species.

If you change any block properties for any of these split blocks, the
change will propagate to each split block. For example, if you change the
appearance of the block, the change affects all split blocks.

Note You can split only species blocks.

2 Manually move the split blocks to the desired position.
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protein

1ty

Binding/Unbinding

I
DNA J:rntem
Transcnptlon

Translatlnn

-\

Protein Degradation mRMA Degradatmn

3 From the Diagram menu, select Tools > Diagram Table View to open
the Diagram Table View pane.

Marme Split Hidle:
D2,

protein
DhA_praotein
mRMA,

I
=

Degree

W Protein Degradsation
[ M2 Degradation

Translation

=3 Transcription

| { w { f
|
|

EindingMnkinding

Diagram Table View is a tool that lets you hide or show blocks, split or
combine blocks, and pin or unpin blocks. You can select a single block or
perform the action on multiple selected blocks. Diagram Table View also
shows you the degree of connectivity in your diagram and also lets you view
a histogram of the degree of connectivity.

4 In the row for the protein Species block, clear the Split check box. The
diagram combines the split blocks. Alternatively, you can right-click the
Species block and select Combine Split Blocks.

5 Select the row for the Transcription Reaction block and press
Ctrl+left-click to select the row for the mRNA Species block. Ctrl+click lets
you select discontinuous rows.
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6 Right-click and select Pin Selected Blocks. The diagram pins the blocks.
You cannot move pinned blocks manually or with automatic layout. Note
the indicator for pinned blocks in the following diagram.

2
ElindingIUnbiW

DNA_protein @
&I'Transcription
Translation 2
protein [=——~0O~--~ m

Protein Dégradatinn mRMA Dégradatinn

7 Select the row for the Protein Degradation reaction and press
Shift+left-click to select the row for the mRNA Degradation reaction.

8 Right-click and select Hide Selected Blocks. The diagram hides the two
reactions in the diagram. The reaction rows are visible in the Diagram
Table View pane.

Note Hiding a block only hides it graphically. The block is still
represented in the mathematical model.

9 Select a block, right-click and select Rotate Clockwise to rotate the
selected block.

10 Select Diagram > Show All Hidden Blocks and Lines to see all blocks.

11 Click M in the Diagram Table View toolbar.
The SimBiology desktop opens a figure window with a histogram of the

degrees of connectivity plotted as the number of connections versus the
number of blocks.
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#of Blocks

1 2 3 4

# of Degrees

You can also see the degree of connectivity in the Degree column.

Changing the Diagram Layout Automatically

From the Diagram menu, select Layout All Elements or Only the
Selected Elements to use the automatic layout feature. Select blocks and
use the automatic layout feature to lay out only the selected blocks in the
diagram.

Automatic layout works only on blocks that are not pinned. You can right-click
and select Unpin Block if you want to lay out all blocks. Leave blocks pinned
if you do not want the position of the block to change during layout.

This example starts with the blocks for mRNA and Transcription pinned.

The default settings for automatic layout should work well for many models.
You can optionally change the automatic layout settings in the SimBiology
desktop.

To change the settings for automatic layout:

1 Right-click the diagram background and select Properties. The Diagram
Properties dialog box opens.
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2 Click the Layout Diagram tab.

__1 Diagram Properties

Setting I Appearance |

Murnber of Layout Iterations:
f500

Timeout (Maximum kime available For layout in millseconds):
f10000.0

Maximum Distance (Maximum distance a block can be moved in one layout ikeration):
f1000.0

Line Spring Constant (How strongly the blocks attract each other):
f3.0E-5

Line Spring Length (Desired length for each line):
fo.0

Repulsion Limit (Distance beyvond which blocks no longer attract each other):
J+00.0

Refresh Rate (Rate the diagram is updated during layout in miliseconds):

f1000
Layout Diagram |
Close |

3 In the Number of Layout Iterations box, enter the number of iterations
to include in the layout. The default is 500. More iterations give you a
better layout, but also take more time. For example, enter 700.

4 In the Timeout box, enter the maximum amount of time available for
layout. The default is 10000.0 milliseconds.

5 In the Maximum Distance box, specify the distance that a block moves in
one iteration. The default is 1000.0. If you enter a smaller value, layout is
slower. Large values can also cause oscillation in the layout. For example,
enter 50.

6 In the Line Spring Constant box, specify the strength with which the
lines between blocks pull blocks together. The default is 3.0E-5. Increasing
the spring constant creates more compact diagrams by increasing the
spring attraction. For example, enter 2.0E-6 and click Layout Diagram
to apply the settings.

2-33



2 Building SimBiology® Models

2-34

The layout should resemble the following diagram.

DNA_protein

Binding/Unbinding
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r-‘ mRMNA Dégradatinn

i
Translation

Protein Degradation

7 In the Line Spring Length box, specify the length for each line. The
default is 0.0, indicating that force due to the spring is 0 at this length.
Compress this length to push the blocks further apart. For example, enter
10.

8 In the Repulsion Limit box, specify the maximum repelling distance that
limits the distance at which blocks repel each other. The default is 400.0.
Setting this to a large distance causes all blocks to repel each other. This
spreads the diagram out. A smaller value allows only nearby blocks to
repel, creating a more uniformly filled diagram. For example, enter 200.

9 In the Refresh Rate box, enter the rate (in milliseconds) at which the
diagram is updated during layout. The default is 1000. For example, enter
500 and click Layout Diagram to apply the settings.

10 Click Close to close the Diagram Properties dialog box.

11 In the Diagram pane, right-click the DNA species block and select Split
Block.

12 In the Diagram Table View pane, clear the Pin check boxes for the
Transcription Reaction block and the mRNA Species block.
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13 From the Diagram menu, select Layout All Elements or Only the
Selected Elements. Your diagram should resemble the following diagram,
but may be different depending on the diagram layout before you applied
automatic layout.

1

DNA_protein

Binding/Unbind

&i‘TranscriptiDn

! 3]
Trans_l‘a'iinn mRMNA Degradation

Protein Dégradatiun

How the SimBiology Desktop Does Diagram Layout

The automatic layout feature in the SimBiology desktop arranges blocks using
a simple “force directed” algorithm.

Every block is affected by three forces:

e Edges of the diagram repel blocks.

® Blocks repel each other.

® Lines between blocks act as springs that draw blocks toward each other.
The algorithm tries to minimize the sum of these forces. In each iteration, the
SimBiology desktop calculates the total force on each block. The diagram then

moves each block in the direction of and proportional to the force acting on it.
Two adjustable parameters control the dynamics of the layout:
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® The number of iterations that are taken determines how long the layout
takes and thereby how well it can do.

® The maximum distance constrains the distance that any block will be
moved in one iteration. A small value makes layout progress go slowly. A
large value may cause oscillation in the layout.

Three adjustable parameters influence the layout of the diagram:

® The spring constant controls how strongly the lines between blocks pull
blocks together. Increasing the spring constant creates more compact
diagrams as the spring attraction dominates the repulsion between blocks.

® The spring length controls the “natural length” of the lines between
blocks. The force due to the spring is zero at this length. When a spring is
compressed to less than this length, it pushes the blocks apart.

® The maximum repelling distance limits the distance at which blocks repel
each other. Setting this value to a large distance causes all blocks to repel
each other. This spreads the diagram out. A smaller value allows only
nearby blocks to repel, creating a more uniformly filled diagram.

Printing and Exporting the Diagram

You can annotate and print your pathway diagram, or you can export the
diagram to .svg, .jpeg, or .pdf file formats. For example, you can annotate
the diagram with the name of the author, the date, notes, and name of the
organization. You can choose to place the content as a header or footer on
the diagram page.

Printing a Diagram

Right-click in the SimBiology diagram and select Print to open the Print
dialog box and print the diagram. By default there are no annotations.
However, if you previously annotated the diagram using Diagram Print
Setup, the printed document contains the annotations. You can access
Diagram Print Setup from the diagram’s right-click (context) menu.

To annotate and print a diagram:

1 In the Diagram pane, right-click the background of the diagram and select
Diagram Print Setup.
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The Diagram Print Setup dialog box opens.

2 In the Diagram Options tab, do the following:

a In the Scale box, select the size to adjust the diagram to (100% is the
default size). Alternatively, click the Fit diagram to button and specify
the desired width and height.

b Clear the Print frame around diagram check box if you do not want
a frame in the printed document.

3 Click the Page Annotation tab.

4 Click Edit. The Customize Page Annotation dialog box opens. This dialog
box lets you enter and store customized information for print annotation.

a In the relevant fields, enter the name of your organization and your
name.

b From the Date Format and Page Format lists, select the date and
page formats respectively.

¢ Click OK.

5 Place the cursor in a Header or Footer box and click Author,
Organization, Model, or Date.

The SimBiology desktop inserts the information entered in the Customize

Page Annotation dialog box. Alternatively, you can type information into
each field.

6 In the Diagram Notes box, enter notes to be included.

7 From the notes location list, select whether to include notes in the printout,
and the location. You can also choose to include the notes only on the first
page.

8 Click Close to exit the Diagram Print Setup dialog box.

Alternatively, click Print to open the Print dialog box and print the
diagram.
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Exporting a Diagram Image

You can export the image of a pathway diagram in a portable file format for
use by other software such as the Microsoft® PowerPoint® application. The
SimBiology desktop exports the graphical representation of the model.

1 In the Diagram pane, right-click the background of the diagram and select
Export Diagram As.

The Export Diagram As dialog box opens.
2 From the File type list, specify the type of file to export.
3 Click ... (Browse) to choose the file location.
4 In the File name box, specify the file name.

5 Keep the default selection for the Preserve aspect ratio check box to
preserve the width and height ratio of the diagram.

6 (Optional) Specify the desired width and height of the image in inches, in
the Width and Height boxes respectively.

7 Click OK to export the file.
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In this section...
“About This Example” on page 2-39

“Creating a SimBiology Model” on page 2-39

“Adding the Reaction for Transcription” on page 2-41

“Adding the Reaction for Translation” on page 2-42

“Adding the Reactions for Gene Regulation” on page 2-42

“Adding the Reactions for mRNA and Protein Degradation” on page 2-43
“Simulating the Model with an ODE Solver” on page 2-44

“Simulating the Model with a Stochastic Solver” on page 2-46

About This Example
This section shows how to model a simple gene-regulation pathway using

M-code and the command-line interface. For more information about this
model, see “Gene Regulation Model” on page 2-2.

You can also use a graphical user interface (see “Modeling Using the
SimBiology Graphical User Interface” on page 2-8 and “Modeling Using the
SimBiology Diagram” on page 2-16). A comparison of the three methods will
help you understand the model objects that are created, how to access and
edit a model through the MATLAB Command Window, and enable you to
determine the workflow of your preference.

Creating a SimBiology Model

A SimBiology model is a collection of objects that are structured hierarchically.
At least one model object is needed to contain all the other objects.

1 Create a model object. For example, to create a model with the name cell,
in the MATLAB Command Window, type

Mobj = sbiomodel('cell')
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MATLAB creates a model object (Mobj) in the workspace and displays a
summary of the objects in the model.

SimBiology Model - cell

Model Components:
Compartments:
Events:
Parameters:
Reactions:
Rules:

Species:

O OO O0OOoOo

2 Display all the model object properties by typing
get(Mobj)

MATLAB displays a list of properties for the model object and their current
values.

Annotation:
Events: [0x1 double]
Name: 'cell'
Notes: "'
Parameters: [Ox1 double]
Parent: [1x1 SimBiology.Root]
Species: [0x1 handle]
Compartments: [0Ox1 double]
Reactions: [0Ox1 double]
Rules: [0x1 double]
Tag: '
Type: 'sbiomodel'’
UserData: []

Some of the model properties are themselves objects or arrays of objects.
3 Add a compartment named contents to the model.
compObj = addcompartment(Mobj, 'contents');

All models must contain a compartment. You can either add a compartment
and specify its name (as shown here), or you can let the process of adding a
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reaction automatically create a default compartment (unnamed) and add the
reaction species to that compartment. You can rename the compartment
later.

If there are multiple compartments in the model, you must

specify the reactants and products using qualified names
(compartmentName.speciesName). For example, nucleus.DNA denotes the
species DNA in the compartment nucleus.

This example contains only one compartment.

Adding the Reaction for Transcription

A simple model of transcription shows only the DNA and mRNA. For more
details, see “Transcription” on page 2-3.

1 Enter the reaction DNA -> DNA + mRNA with reaction rate equation
v=K*DNA.

Robj1 = addreaction(Mobj, 'DNA -> DNA + mRNA');
Kobj1 addkineticlaw(Robj1, 'MassAction');

The property KineticLawName is set to 'MassAction'. Because the
reaction is enough information to determine the rate equation, the property
Expression is set to 'MassAction' and the reaction rate expression is
assumed to be 'k*DNA'.

Since this example has only one compartment, you need not specify
the compartment to which each species belongs. If there are multiple
compartments, here is an example of the reaction syntax:

Robj1 = addreaction(Mobj, 'nucleus.DNA -> nucleus.DNA + cytoplasm.mRNA');

nucleus and cytoplasm are the names of the compartments.

2 Define the reaction rate constant k1=0.2. For a first-order reaction, the
property ParameterVariableNames has a single rate constant that needs
defining. First create a parameter object named k1, and then use the
parameter object name to set the rate constant in ParameterVariableNames
to that object.

Pobj1 = addparameter(Kobj1, 'k1', 0.2);
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set(Kobj1, 'ParameterVariableNames', 'k1');

3 Enter the initial amount for the species DNA= 50 and mRNA = 0. Select the
species using the function sbioselect, which returns an object.

Sobj1 = sbioselect('Type', 'species', 'Name', 'DNA');
set(Sobj1, 'InitialAmount', 50);

The value for mRNA defaults to 0.
4 Check the initial amounts for the species.
Mobj.Species
MATLAB displays a summary list.
SimBiology Species Array

Index: Compartment: Name: InitialAmount: InitialAmountUnits:
1 contents DNA 50
2 contents mMRNA 0

Adding the Reaction for Translation

A simple model of translation shows only the mRNA and protein product. For
more details, see “Translation” on page 2-4.

1 Enter the reaction mRNA -> mRNA + protein with reaction rate equation
v = k*mRNA.

addreaction(Mobj, 'mRNA -> mRNA + protein');
addkineticlaw(Robj2, 'MassAction');

Robj2
Kobj2

2 Define the reaction rate constant k2.

Pobj2 = addparameter(Kobj2, 'k2', 20.0);
set(Kobj2, 'ParameterVariableNames',6 'k2');

Adding the Reactions for Gene Regulation

Transcription of DNA to mRNA is regulated by the binding of the protein
product from translation to the DNA. As more protein is produced, the DNA is
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bound with the protein more often and less time is available for transcription
with the unbound DNA. For more details, see “Gene Repression” on page 2-4.

1 Enter the forward reaction for DNA + protein -> DNA_ protein with a
forward reaction rate equation v = K3*DNA*protein and a reverse rate v
= K3r*DNA:protein.

Robj3 = addreaction(Mobj, 'DNA + protein -> DNA _protein');
Kobj3 addkineticlaw(Robj3, 'MassAction');

Pobj3 = addparameter(Kobj3, 'k3', 0.2);

set(Kobj3, 'ParameterVariableNames', 'k3');

2 Enter the reverse reaction.

Robj3r = addreaction(Mobj, 'DNA_protein -> DNA + protein');
Kobj3r = addkineticlaw(Robj3r, 'MassAction');

Pobj3r = addparameter(Kobj3r, 'k3r', 1.0);

set(Kobj3r, 'ParameterVariableNames', 'k3r');

Adding the Reactions for mRNA and Protein
Degradation

Protein and mRNA degradation are important reactions for regulating
gene expression. The steady-state level of the compounds is maintained
by a balance between synthesis and degradation reactions. Proteins are
hydrolyzed to amino acids with the help of proteases, while nucleic acids
are degraded to nucleotides.

1 Enter the reaction for mRNA degradation to nucleotides.

Robj5 = addreaction(Mobj, 'mRNA -> null');
Kobj5 addkineticlaw(Robj5, 'MassAction');
Pobj5 = addparameter(Kobj5, 'k5', 1.5);
set(Kobj5, 'ParameterVariableNames','k5');

2 Enter the reaction for protein degradation to amino acids.

Robj6 = addreaction(Mobj, 'protein -> null');
Kobj6 addkineticlaw(Robj6, 'MassAction');
Pobj6 = addparameter(Kobj6, 'k6', 1.0);
set(Kobj6, 'ParameterVariableNames','k6');
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Simulating the Model with an ODE Solver

After you create the model, enter reactions, and set parameters, you can
simulate the dynamic behavior of a model.

1 Get a listing of the configuration set attached to the model.
cs = getconfigset(Mobj)
The configuration set object defines the parameters needed for a simulation.
MATLAB displays a listing of the configuration set property values.

Configuration Settings - default (active)

SolverType: ode15s

StopTime: 10.000000
SolverOptions:

AbsoluteTolerance: 1.000000e-006

RelativeTolerance: 1.000000e-003

SensitivityAnalysis: false
RuntimeOptions:

StatesTolLog: all
CompileOptions:

UnitConversion: false

DimensionalAnalysis: true

SensitivityAnalysisOptions:
InputFactors: 0
Outputs: 0

To change simulation stop time you can use the following syntax:
set(cs, 'StopTime', 8.0);
In this example leave the stop time at the default (10.0)

2 Run the simulation.

[t_ode, x_ode] = sbiosimulate(Mobj, cs);
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3 Plot the results.

figure;

set(gcf, ‘color', 'white');

plot(t_ode, x_ode(:,1:4));

title('Gene Regulation - ODE15s Solver');
xlabel('Time (seconds)');

ylabel('Species Amounts');

MATLAB plots a figure with the simulation results. Note that you can
interactively add annotations to the plot as shown in the figure below:

Gene Regulation - ODE15s Solver
50 . . T

— DNA
mEMNA
protein
— DMA_protein

45| -

35r 1
30r 1

251 1

Species Amounts

Time (seconds)

See Also

¢ “Performing Simulations”

e “Stiff Deterministic Solvers” — Brief description of when to use stiff
deterministic solvers solvers and the types available in the software.
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Simulating the Model with a Stochastic Solver

SimBiology software includes three stochastic solvers. The stochastic solvers
more accurately calculate the change in species amounts with a small number
of molecules.

1 Get the active configuration set for a model.
cs = getconfigset(Mobj);
2 Select the stochastic solver and list the configuration set properties.

set(cs, 'SolverType', 'ssa');
cs

MATLAB displays properties for the current configuration set. Notice that
the SolverOptions for the stochastic solver are different from the ODE
options.

Configuration Settings - default (active)

SolverType: ssa

StopTime: 10.000000
SolverOptions:

LogDecimation: 1
RuntimeOptions:

StatesTolLog: all
CompileOptions:

UnitConversion: false

DimensionalAnalysis: true

SensitivityAnalysisOptions:
InputFactors: 0
Outputs: 0
3 Change the value for the LogDecimation property.

cs.SolverOptions.LogDecimation = 10;

This allows you to record fewer data points.
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4 Run the simulation.

[t_ssa, x_ssa] = sbiosimulate(Mobj, cs);

5 Plot the results.

FH1 = figure;

set(gcf, ‘color', 'white');
plot(t_ssa,x_ssa(:,1:4));

title('Gene Regulation with SSA Solver');
xlabel('Time (second)');

ylabel('Amount (molecule)');

set(gcf, ‘color', 'white');

axis([0, 10, 0, 50]);

The resulting plot may resemble the following figure. Add labels by
selecting Text Arrow from the Insert menu.

Gene Regulation with 334 Salver
5':' T LI T T

45

40

L
o m

]
)

Amount (rmolecule)
)
M

e —
o m

Time (second)
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6 Another method to visualize stochastic simulations is through ensemble
runs.

simDataObj = sbioensemblerun(Mobj, 10, cs);
sbiosubplot(simDataObj);

The resulting plot may resemble the following:

) Figure 1 M=l B3
File Edit View Insert Tools Desktop Window Help N
Run1 Run2
60 80
- — DA
w A0 " mRMNA,
% % 40 protein
i i —— DMA_protain
20 —
20
0 0
0 5 10 0 5 10
iy iy
uni ur
G0 80
G0
g 2
= = 40
iG] iG]
20
20
0 =Nl 0 vy
0 5 10 0 5 10
Time Time
==Back | Choose Plets | Showing run(s) 1,2, 3 and 4 of 10 _==Forward |

¢ (Click Back or Forward to navigate through the plots.

¢ (Click Choose Plots to select and view the results of specific runs.

Note To clean up the model object from the Workspace type

delete(Mobj);
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See Also

¢ “Performing Simulations”

® “Stochastic Solvers” — Brief description of when to use stochastic solvers
and the types available in the software.

2-49



2 Building SimBiology® Models

2-50



G

gene regulation
GUI desktop 2-8
GUI Diagram 2-16
model diagram 2-2
reaction list 2-2
reactions 2-3
tutorial model 2-2

K

Kinetic Law
object definition 1-32

M

model
adding reactions 2-10 2-20 2-41
creating 2-8 2-16
creating command-line 2-39
gene regulation 2-42
project file 2-9 2-20
protein degradation 2-43
simulating 2-15 2-24
translation 2-42

P
parameters
definition 1-33
object definition 1-33
R

Rate constants. See parameters
reaction rate

definition 1-32
reactions

degradation 2-43

gene regulation 2-42

object definition 1-31

transcription 2-41

translation 2-42
rules

object definition 1-33

S

SimBiology
computation with MATLAB 1-2
defined 1-2

expected user 1-3
features and functions 1-16
model component definitions 1-29
optional software 1-4
related software 1-5
required software 1-4
SBML support in 1-26
visualizing data 1-2
simulation
ODE solver 2-44
stochastic solver 2-46
software
optional 1-4
required 1-4
Species
object definition 1-31

T

tutorial
basic 2-1
command-line 2-39
tutorial models
gene regulation 2-2

Index-1



	toc
	Introduction
	Product Overview
	Integrated Environment
	Expected Users
	Required Software
	Optional Software
	Related Software

	Integrating SimBiology Models into Your Existing Workflow
	Existing Workflow in Experimental Research
	Workflow Incorporating Mathematical Modeling
	Workflow Using SimBiology Models for Mathematical Modeling

	Getting Started in the SimBiology Desktop
	Overview
	Creating or Opening a Model Using the New Project Wizard
	Opening a SimBiology Project

	Features and Functions
	Using the Command Line versus the SimBiology Desktop
	Graphical User Interface
	Customizing Desktop Views and Preferences

	Command-Line Interface
	Data Formats and Projects
	Modeling
	Simulation
	Analysis

	SimBiology Support and SBML
	What Is SBML?
	SBML Support
	Importing SBML Files
	Converting a SimBiology Model to SBML Format
	Example

	SimBiology Model Components
	Organization of SimBiology Objects
	Model
	Compartment
	Species
	Reaction
	Kinetic Law
	Reaction Rate Equation

	Parameters
	How to Use Scope
	Rules
	Events
	Configuration Sets
	Variants
	Simulation Data


	Building SimBiology Models
	Gene Regulation Model
	Model Diagram
	Model Reactions
	Transcription
	Translation
	Gene Repression
	Degradation

	Opening the Gene Regulation Model in the SimBiology Desktop

	Modeling Using the SimBiology Graphical User Interface
	About the Model Used in This Tutorial
	Creating a Model
	Saving Your Work as a SimBiology Project File
	Adding Reactions to a Model
	About Scope
	Simulating a Model

	Modeling Using the SimBiology Diagram
	About This Example
	Creating a Model
	Saving Your Work as a SimBiology Project File
	Adding Reactions to a Model Diagram
	Simulating a Model
	Setting Block Appearance and Diagram Layout
	Changing Block Appearance
	Applying Block Appearance Styles
	Changing the Diagram Layout Manually
	Changing the Diagram Layout Automatically
	How the SimBiology Desktop Does Diagram Layout

	Printing and Exporting the Diagram
	Printing a Diagram
	Exporting a Diagram Image


	Modeling Using the Command-Line Interface
	About This Example
	Creating a SimBiology Model
	Adding the Reaction for Transcription
	Adding the Reaction for Translation
	Adding the Reactions for Gene Regulation
	Adding the Reactions for mRNA and Protein Degradation
	Simulating the Model with an ODE Solver
	See Also

	Simulating the Model with a Stochastic Solver
	See Also



	Index


